Power Manager 5.7 Released

We are pleased to announce the launch of Power Manager 5.7. This update changes how Pluggable Authentication Modules (PAM) are used in preparation for the next version of macOS.

Power Manager requires macOS 10.12 or later.

Updating Power Manager

Power Manager will automatically check for updates every so often, so there is nothing to do. The update will automatically be offered to you during the next few weeks.

If you want to update to the latest Power Manager now, use the Check for Updates menu item in the Power Manager menu. In case of problems, please follow the manual update steps.

Photograph of berries ripening in the garden

Changes in v5.7

  • Change: Use built-in sudo PAM profile to authenticate as an administrator (macOS 12).
  • Change: Removed custom PAM profile /etc/pam.d/uk.co.dssw.powermanager; destination SIP locked (macOS 12).
  • Bug: Fixed bugs and potential memory leaks to improve stability.

Changes in v5.7.1

  • Bug: Fixed unexpected signal in pmctl (golang://47776).

A detailed version history of Power Manager is also available.

This article was posted in , and and tagged .

Published by Graham Miln on