We aim to support the three latest major versions of Mac OS X. Beyond the supported versions, we continue to provide technical support but do not provide code updates.

While no longer supported with updates, these older versions of Power Manager can still be deployed on older Macs.

A licence is required to use Power Manager for longer than the 30 day demonstration period. A Power Manager 4 licence purchased today will work on earlier versions.

Mac OS X 10.6 – Snow Leopard

Version 4.1.8 was the last version to support Mac OS X 10.6.

Download Power Manager for Snow Leopard

Technical Details
Version 4.1.8
Requires Mac OS X 10.6 – 10.9
Architecture Intel; 32 and 64-bit

Mac OS X 10.4 – Tiger – and PowerPC

Version 4.1.2 was the last version to support the PowerPC architecture.

Download Power Manager for PPC

Technical Details
Version 4.1.2
Requires Mac OS X 10.4 – 10.7
Architecture Intel and PowerPC; 32 and 64-bit

Looking for earlier versions of Power Manager? See our unsupported page for older versions and downloads.