The conversation on this page has been archived and is no longer active.

airport network no longer defaults properly after wake-up

Message #1 - Posted 2007/01/16 - D P Schreber

Not sure how I did this, but as of yesterday, when my MBP wakes from sleep it no longer defaults the wireless network. I have to select one manually from the AirPort menu icon. Before this, my local AirPort network would be selected automatically on wake-up.

The AirPort configuration in the Network system preference still says 'By default, join <A specific network>', my preferred network is still listed as the one to join, and my login keychain still has the right WPA password. Afaik I didn't make any network configuration or keychain changes of any kind.

How can I get the old behavior back?

Message #2 - Posted 2007/01/16 - Paul Nevai

D P Schreber wrote:

Not sure how I did this, but as of yesterday, when my MBP wakes from sleep it no longer defaults the wireless network. I have to select one manually from the AirPort menu icon. Before this, my local AirPort network would be selected automatically on wake-up.

The AirPort configuration in the Network system preference still says 'By default, join <A specific network>', my preferred network is still listed as the one to join, and my login keychain still has the right WPA password. Afaik I didn't make any network configuration or keychain changes of any kind.

How can I get the old behavior back?

I had the same and asked here but none of the recommendations worked. It turned out to be a KeyChain problem. Check the preferences in the AirPort's KeyChain entry. They need to be fixed. /PaulN

Message #3 - Posted 2007/01/16 - D P Schreber

On 2007-01-16, Paul Nevai wrote:

I had the same and asked here but none of the recommendations worked. It turned out to be a KeyChain problem. Check the preferences in the AirPort's KeyChain entry. They need to be fixed. /PaulN

Hmm. The login keychain item for the Airport network password hasn't been touched in months, but the system keychain was changed yesterday. So that certainly looks like the source of the problem. But I've never known how to modify system keychain items: it wants some password that's not my login keychain password. I have no idea where this system keychain password would come from, given that mine is the only account that exists on the machine. I suppose I could just delete it and see what happens.

In any case, thanks for the clue.

Message #4 - Posted 2007/01/21 - Randy Howard

On Tue, 16 Jan 2007 05:57:45 -0600, D P Schreber wrote (in a previous article):

Not sure how I did this, but as of yesterday, when my MBP wakes from sleep it no longer defaults the wireless network. I have to select one manually from the AirPort menu icon. Before this, my local AirPort network would be selected automatically on wake-up.

The AirPort configuration in the Network system preference still says 'By default, join <A specific network>', my preferred network is still listed as the one to join, and my login keychain still has the right WPA password. Afaik I didn't make any network configuration or keychain changes of any kind.

How can I get the old behavior back?

I've had this happen occasionally myself, but not consistently enough to track it down.

Randy Howard (2reply remove FOOBAR)
"The power of accurate observation is called cynicism by those who have not got it." - George Bernard Shaw

Message #5 - Posted 2007/01/26 - Scott

On 2007-01-16 18:46:36 -0800, D P Schreber said:

On 2007-01-16, Paul Nevai wrote:

I had the same and asked here but none of the recommendations worked. It turned out to be a KeyChain problem. Check the preferences in the AirPort's KeyChain entry. They need to be fixed. /PaulN

Hmm. The login keychain item for the Airport network password hasn't been touched in months, but the system keychain was changed yesterday. So that certainly looks like the source of the problem. But I've never known how to modify system keychain items: it wants some password that's not my login keychain password. I have no idea where this system keychain password would come from, given that mine is the only account that exists on the machine. I suppose I could just delete it and see what happens.

In any case, thanks for the clue.

Were you able to get this resolved?

I have the same problem. I followed the apple knowledgebase article but a few times a week I still need to manually select my SSID. It seems to happen more often if I wake my MacBook up shortly after putting it to sleep.

Message #6 - Posted 2007/01/26 - D P Schreber

On 2007-01-26, Scott wrote:

Were you able to get this resolved?

Not the keychain issue - I still don't know how to modify entries in the System keychain. But after searching further in the archives I found a suggestion to create a new location using Network Prefs. I did that, threw away the existing Automatic location, and made the new one the default. I also renamed it Automatic but I doubt that's necessary. Now my local airport network is selected properly after wakeup.

Fwiw the original Automatic location was configured to use a 'specific network'. Now I don't even see that option anymore, so the new one uses 'preferred networks' where my own lan is the only entry in the list. I removed all the others that showed up initially -- there are 5-10 wireless networks accessible from my apartment, depending what side of the building I'm on.

Interestingly (to me, anyway), this new setup uses an entry from my login keychain and does nothing at all with the system keychain.

Message #7 - Posted 2007/01/26 - Jolly Roger

On 2007-01-26 06:27:23 -0600, D P Schreber said:

Fwiw the original Automatic location was configured to use a 'specific network'. Now I don't even see that option anymore

You're not the first to report this. The previous person who reported it, IIRC, found a solution that got the option back. If I were you, Google would be my best friend about now...

JR

Message #8 - Posted 2007/01/27 - Eric Lindsay

Previously, Jolly Roger wrote:

On 2007-01-26 06:27:23 -0600, D P Schreber said:

Fwiw the original Automatic location was configured to use a 'specific network'. Now I don't even see that option anymore

You're not the first to report this. The previous person who reported it, IIRC, found a solution that got the option back. If I were you, Google would be my best friend about now...

Similar issue, wireless network being lost after sleep. I believe it started after the first security update of the year. System Preferences, Network, and telling Automatic to keep using the network I originally asked it to prefer seems to have fixed it. It took a while for me to notice it was happening each morning (at 6 in the morning I am running on auto myself).

Need Help? Have a Question?

Looking for more help, comments, and answers?

Ask your questions on Ask Different. Ask Different is a community of Apple users ready to help.