The conversation on this page has been archived and is no longer active.

Apache on Mac OS X doesn't work if the OS sleeps

Message #1 - Posted 2001/11/12 - Ziv Gillat

Hi,

As soon as Mac OS X (10.1) sleeps, Apache stops accepting incoming requests. I have to make sure that I never put the system to sleep. Just the monitor and the drive are OK to sleep. In Mac OS 9, this was fine with FileSharing, and sleeping.

Any ideas how I can overcome this, besides not ever sleeping?

Thanks ---

Ziv

Message #2 - Posted 2001/11/12 - R Shapiro

Previously, Ziv Gillat wrote:

Any ideas how I can overcome this, besides not ever sleeping?

Disable general sleep and instead enable separate sleep for the display and the drive.

remove xxx to reply

Message #3 - Posted 2001/11/12 - Burghard W.V. Britzke

there has been a check button at mos9 to "wake up on network access". hoping this button re-appears in future releases.

R Shapiro schrieb:

Previously, Ziv Gillat wrote:

Any ideas how I can overcome this, besides not ever sleeping?

Disable general sleep and instead enable separate sleep for the display and the drive.

--
remove xxx to reply

Message #4 - Posted 2001/11/12 - Tim McNamara

Previously, Ziv Gillat wrote:

As soon as Mac OS X (10.1) sleeps, Apache stops accepting incoming requests. I have to make sure that I never put the system to sleep. Just the monitor and the drive are OK to sleep. In Mac OS 9, this was fine with FileSharing, and sleeping.

Any ideas how I can overcome this, besides not ever sleeping?

You have found the solution. Let the drive and display sleep, but do not let the system sleep.

Message #5 - Posted 2001/11/13 - R Shapiro

Previously, Burghard W.V. Britzke wrote:

there has been a check button at mos9 to "wake up on network access". hoping this button re-appears in future releases.

OSX has a similar checkbox. I don't know if it works for http requests but it definitely doesn't for ssh requests, or at least it didn't in 10.0. When 10.0 goes to sleep it seems to shut down ethernet altogether.

remove xxx to reply

Message #6 - Posted 2001/11/12 - Jim Meiss

Previously, R Shapiro wrote:

Previously, Burghard W.V. Britzke wrote:

there has been a check button at mos9 to "wake up on network access". hoping this button re-appears in future releases.

OSX has a similar checkbox. I don't know if it works for http requests but it definitely doesn't for ssh requests, or at least it didn't in 10.0. When 10.0 goes to sleep it seems to shut down ethernet altogether.

Similarly in 10.1...you can't use appleshare or ssh to get to a computer (at least to mine) when it is asleep.

Message #7 - Posted 2001/11/13 - M. Perry

This is because sleep really is sleep and not a light nap. Chron doesn't run either, which means that middle of the night clean up scripts often aren't getting executed.

I suspect the solution is to put the screen and perhaps the hard drive to sleep and let everything else run.

Similarly in 10.1...you can't use appleshare or ssh to get to a computer (at
least to mine) when it is asleep.

Message #8 - Posted 2001/11/14 - Ziv Gillat

Thanks everyone for all your help :-)

Message #9 - Posted 2001/11/23 - Shrubya

Ziv Gillat wrote:

As soon as Mac OS X (10.1) sleeps, Apache stops accepting incoming

Any ideas how I can overcome this, besides not ever sleeping?

Umm... servers should not ever sleep.

Need Help? Have a Question?

Looking for more help, comments, and answers?

Ask your questions on Ask Different. Ask Different is a community of Apple users ready to help.