The conversation on this page has been archived and is no longer active.

Battery won't charge

Message #1 - Posted 2004/04/25 - James Chokey

Here's the quick story: 3 days ago, I tried to start up my Powerbook from the battery, as I usually do. Didn't work, so I plugged it in and it started up fine. The battery monitor at the top of the screen said 0%, indicating the battery was completely devoid of charge.

So, I left it plugged in for a day... the next day, still no charge. I double-checked to make sure everything all the cords had been connected-- they were. And the machine would start up just fine using the plug-- so clearly power was getting through to the machine, it just wasn't going into charging the battery. The little icon for the monitor also didn't have the little lighting bolt sign on it that it usually does when it is charging.

I live near an Apple Store (Burlingame, California) so I took it down to the "Genius Bar" there to have the fellow there look at it. After some back and forth with the fellow on duty (who intially insisted that it was charging fine, in spite of the fact that wasn't), he went ahead and reset the PMU (Power Management Unit) inside of the machine.

That seemed to do the trick... briefly. After he did that, the machine started to charge the battery just fine. When I turned it on (still plugged in), the lightning bolt had returned to the icon, and we had gone up from 0% to 1%. Well, I took the machine home, left it plugged in for a few hours, and at around midnight, I tested it again. The battery was back up to 99% charge. I shut down, unplugged it, and tried to restart from the battery. Again, it worked fine. So, I replugged it in and went to sleep, thinking all was solved.

This morning, I woke up, took the Powerbook downstairs, and tried to start up. Didn't work. I plugged it in and it started up fine.... and lo and behold, the battery monitor revealed that the battery was drained again... down to 0%! I tried resetting the PMU on my own (I saw what the "Genius" did yesterday and read the Apple pages help section on this, so I'm pretty sure I did it correctly. (I also tried resetting the PRAM beforehand as well, per the Apple Pages suggestions). This time, it did nothing. Nada. Zilch. Upon restart, the battery monitor icon still showed no lightning bolt, and despite being plugged in for an hour, there's no sign of charging.

Any thoughts on what this is? The battery? The charging mechanism inside the machine? Something else?

Need Help? Have a Question?

Looking for more help, comments, and answers?

Ask your questions on Ask Different. Ask Different is a community of Apple users ready to help.