The conversation on this page has been archived and is no longer active.

Disk won't spin down

Message #1 - Posted 2003/10/16 - Peter Renzland

Dual USB iBook, 500Mhz, 10.2.8

Energy Saver has an option:
"Put hard disk to sleep when possible"
But it won't, especially not when on battery. :-)

Has anyone been able to do this?
Do you have to kill cron?

Thanks for any help with this.

-- Peter

Message #2 - Posted 2003/10/17 - John Johnson

Previously, Peter Renzland wrote:

Dual USB iBook, 500Mhz, 10.2.8

Energy Saver has an option:
"Put hard disk to sleep when possible"
But it won't, especially not when on battery. :-)

Has anyone been able to do this?
Do you have to kill cron?

Thanks for any help with this.

-- Peter

How much RAM do you have? If you don't have enough, your disk will be accessed for virtual memory (pageout) purposes. Otherwise, it's some application or process that keeps the disk in use. Try turning off apps until the disk eventually shuts down.

Message #3 - Posted 2003/10/17 - Peter Renzland

John Johnson wrote:

Peter Renzland wrote:

Dual USB iBook, 500Mhz, 10.2.8

Energy Saver has an option:
"Put hard disk to sleep when possible"
But it won't, especially not when on battery. :-)

Has anyone been able to do this?
Do you have to kill cron?

How much RAM do you have? If you don't have enough, your disk will be accessed for virtual memory (pageout) purposes. Otherwise, it's some application or process that keeps the disk in use. Try turning off apps until the disk eventually shuts down.

384 MB; less than half of it touched; no pageouts

Reboot,
no "Apps" running but Finder,
unplug and wait,
disk does *not* spin down.

Has *anyone* here *actually* gotten their iBook disk to sleep? How much inactive time before disk spins down?

Thanks again.

-- Peter

Message #4 - Posted 2003/10/17 - Michael Hismann

Peter Renzland wrote:

Dual USB iBook, 500Mhz, 10.2.8

Energy Saver has an option:
"Put hard disk to sleep when possible"
But it won't, especially not when on battery. :-)

Has anyone been able to do this?
Do you have to kill cron?

10.2.8 starts "update" at startup (/etc/rc), which flushes the HD every 30 seconds.
Dunno if that's the reason.

Michael.

Message #5 - Posted 2003/10/18 - Peter Renzland

Peter Renzland wrote:

Dual USB iBook, 500Mhz, 10.2.8

384 MB

Energy Saver has an option:
"Put hard disk to sleep when possible"
But it won't, especially not when on battery. :-)

Has anyone been able to do this?

O.K. I've been able to get it to spin down.
It takes 10 minutes of idle disk!!!!

Sigh. Would be nice if it could spin down after 1 or 2 minutes. Maybe revving it up is costly.

The following may be helpful in monitoring spindown time:

iostat 10 &
while sleep 60;do; date;done

-- Peter

Message #6 - Posted 2003/10/21 - Kwan Yeoh

Peter Renzland wrote:

Dual USB iBook, 500Mhz, 10.2.8

Energy Saver has an option:
"Put hard disk to sleep when possible"
But it won't, especially not when on battery. :-)

Has anyone been able to do this?

Two things:

1. My iBook used to spin down. Once I installed Norton Utilities, it refused to spin down, except when I force it to (can't remember the keyboard shortcut anymore).

2. I think Cocktail has an option to change the time to spindown.

Please remove SpamMeNot to reply. I apologise for the necessary use of this anti-spammation method.

Message #7 - Posted 2003/10/21 - Mats Weber

Previously, Peter Renzland wrote:

Energy Saver has an option:
"Put hard disk to sleep when possible"
But it won't, especially not when on battery. :-)

The new Energy saver is brain dead. It sets the disk sleep timeout to 5 minutes regardless of battery/charger.

To change that, open a terminal window and type

sudo pmset -a spindown 1

and enter your password. This will make it spin down after 1 minute. You can use -c or -b instead of -a if you want a separate timing for charger and battery.

If you want to know more, see man pmstat

Message #8 - Posted 2003/10/21 - Peter Renzland

Mats Weber wrote:

Peter Renzland wrote:

Energy Saver has an option:
"Put hard disk to sleep when possible"
But it won't, especially not when on battery. :-)

The new Energy saver is brain dead. It sets the disk sleep timeout to 5 minutes regardless of battery/charger.

sudo pmset -a spindown 1

Gruezi, Mats -- that's what I needed. Thanks!!
(Any command to query current spindown setting?)

-- Pete

Message #9 - Posted 2003/10/22 - Jussi Piitulainen

Mats Weber writes:

The new Energy saver is brain dead. It sets the disk sleep timeout to 5 minutes regardless of battery/charger.

On my iBook, 10 minutes, with Mac OS X 10.2.8. (This is seen in the XML file as told by man pmset.)

To change that, open a terminal window and type

sudo pmset -a spindown 1

...

If you want to know more, see man pmstat [should be pmset]

Thank you. I hadn't even realized how silent the disk used to be.

However, the reason I got interested in this thread is that my iBook has developed an irritating noise: a loud and clear tick like a wall clock, roughly a tick per second. It seemed to go on forever, and I could not identify any process that would be accessing disk all the time.

That noise continues even when the disk spins down. What can it be? Should I be worried, or is this normal?

Two USB ports. Screen diagonal about 30 cm, near 12 inches. 800 MHz processor 384 MB memory. Airport card.

Jussi

Message #10 - Posted 2003/10/22 - Peter Renzland

Previously, Peter Renzland wrote:

Mats Weber wrote:

Peter Renzland wrote:

Energy Saver has an option:
"Put hard disk to sleep when possible"
But it won't, especially not when on battery. :-)

The new Energy saver is brain dead. It sets the disk sleep timeout to 5 minutes regardless of battery/charger.

sudo pmset -a spindown 1

Gruezi, Mats -- that's what I needed. Thanks!!
(Any command to query current spindown setting?)

Silly me -- RTFM'd again -- Thanks Jussi!!

-- Pete

Message #11 - Posted 2003/10/22 - Laurent Daudelin

In message , Peter Renzland <phr0206@sympatico.ca> wrote:

Peter Renzland wrote:

Dual USB iBook, 500Mhz, 10.2.8

384 MB

Energy Saver has an option:
"Put hard disk to sleep when possible"
But it won't, especially not when on battery. :-)

Has anyone been able to do this?

O.K. I've been able to get it to spin down.
It takes 10 minutes of idle disk!!!!

Sigh. Would be nice if it could spin down after 1 or 2 minutes. Maybe revving it up is costly.

The following may be helpful in monitoring spindown time:

iostat 10 &
while sleep 60;do; date;done

-- Peter

For some reason, Apple has removed the disk setting in Energy Saver. However, the setting is still in the file that saves the various Energy Saver settings.

You might be able to decrease the 10 minutes wait for the disk to spin down by modifying the value in a text editor. IIRC, the file is named "com.apple.PowerManagement.xml". It is down somewhere under /private/var. You will need root permissions to modify the file, but it's definitely doable. By default, the disk spin down delay is set to the same value than the system sleep delay.

-Laurent.
-- ================================================================= Laurent Daudelin Logiciels Nemesys Software mailto:laurent.daudelin@ihatespam.net <http://nemesys.dyndns.org> Replace ihatespam with verizon to reply
+++++++++++ Sent using an Apple Newton MessagePad 2100 ++++++++++

Message #12 - Posted 2003/10/22 - Henrik Holm

Peter Renzland wrote:

O.K. I've been able to get it to spin down. It takes 10 minutes of idle disk!!!!

Sigh. Would be nice if it could spin down after 1 or 2 minutes. Maybe revving it up is costly.

Cocktail helps you with this, and more.

Top 10 reasons for procrastination:

1)

Need Help? Have a Question?

Looking for more help, comments, and answers?

Ask your questions on Ask Different. Ask Different is a community of Apple users ready to help.