The conversation on this page has been archived and is no longer active.

eMac forced shutdown problem

Message #1 - Posted 2008/06/23 - magdalena

I replaced my eMac 700's PRAM battery two days ago because startup problems. The instructions in the manual say to push the PMU reset button for one second. However, the button did not budge at all (is it supposed to?) when I pushed it with a pen. Since I didn't want to push it second time, I replaced the access panel and restarted the eMac with no problem.

Everything worked fine the rest of the evening and for several hours the next day. Then I decided to add a 512mb memory module from my G4 Sawtooth that I no longer used (eMac uses the same part, according to Crucial and OWC). The eMac recognized the new RAM and all seemed well, but while I wasn't even using the eMac, it shut itself down (about 20 minutes after starting it up). Thinking the RAM was the culprit, I took it out. Restarted, and it shut itself down again 20 or 30 minutes later.

Disk Utility reported the hard disc as fine. I zapped the PRAM, to no avail. We've been having electrical storms for the past two days, but I always unplug all computer equipment during storms. Could small power spikes caused by distant storms be causing the shut downs? It doesn't seem like the apparent inability to push in the PMU reset button is the culprit, since the eMac worked for several hours after I replaced the battery. Of course when these things happen, one tends to think about all possible variables. I have a USB extension on the Apple keyboard. Could that cause problems (although it's been working fine since I got it three weeks ago)???

I just plugged the eMac into an APC battery backup device to see if it shuts itself off while on that. I looked at the system log the last time it shut itself down and there's a item that says:

"Jun 23 19:42:52 localhost kernel[0]: ApplePMU::PMU forced shutdown, cause = -122."

Is it okay to post the whole log here, or will I be banned if I do so? HELP!!! Thanks!

Message #2 - Posted 2008/06/24 - magdalena

I'm posting this in the comp.sys.mac.system group because the hardware group has little traffic, and I really need to get some answers (and my issue is system-related as well as hardware-related).

To recap my previous posts, my eMac was having trouble starting up. I installed a new PRAM battery, and then tried to reset the PMU button, but it would *not* budge (is this normal?). However, the battery seemed to have fixed the startup problem, and all was fine for hours. So I thought it was safe to add some RAM (the correct stick according to Crucial and OWC). But now the eMac shuts down instead of sleeping.* I removed the new RAM, to no avail. (I also zapped PRAM, reset NVRAM, and trashed relevant preferences per another fixit forum.)

*I had EnergySaver set to sleep the computer after 20 minutes of inactivity. I did several tests of 5, 20, and 60 minutes, and it shutdown (instead of sleeping) like clockwork at those points. I did a temporary fix by setting it to sleep *never*. But I would prefer to set it back to 20 minutes so the hard disk is not spinning unnecessarily. Does anyone have any clues for a real fix? Thank you.

Need Help? Have a Question?

Looking for more help, comments, and answers?

Ask your questions on Ask Different. Ask Different is a community of Apple users ready to help.