The conversation on this page has been archived and is no longer active.

How do I disable disconnection on network when PowerBook G4 goes to sleep?

Message #1 - Posted 2004/02/04 - ANTant

I heard it is possible to disable this in MacOS X (10.2.8). How do I do that? I do not see this option in Energy Saver option. I would like to keep AirPort and NIC going during PowerBook G4 (1 Ghz; 15")'s sleep.

Thank you in advance. :)
--
"I'm not afraid of insects taking over the world, and you know why? It would take about a million ants just to aim a gun at me, let alone fire it. And you know what I'm doing while they're aiming it at me? I just sort of slip off to the side, and then suddenly run up and kick the gun out of their hands." --Jack Handy from Saturday Night Live /\___/\
/ /\ /\ \ Ant @ The Ant Farm: http://antfarm.ma.cx

o o| | E-mail: philpi@earthlink.netANT or philpi@apu.eduANT

\ _ / Remove ANT if replying by e-mail from a newsgroup.

( )

Message #2 - Posted 2004/02/04 - Steven Fisher

On Wed, 4 Feb 2004 1:20:39 -0800, ANTant@zimage.com wrote (in message <pv2dnV218av6JL3dRVn-jg@mminternet.net>):

I heard it is possible to disable this in MacOS X (10.2.8). How do I do that? I do not see this option in Energy Saver option. I would like to keep AirPort and NIC going during PowerBook G4 (1 Ghz; 15")'s sleep.

I believe it's only possible on desktop machines. Powerbooks have a depper sleep.

Message #3 - Posted 2004/02/04 - ANTant

Steven Fisher wrote:

On Wed, 4 Feb 2004 1:20:39 -0800, ANTant@zimage.com wrote (in message <pv2dnV218av6JL3dRVn-jg@mminternet.net>):

I heard it is possible to disable this in MacOS X (10.2.8). How do I do that? I do not see this option in Energy Saver option. I would like to keep AirPort and NIC going during PowerBook G4 (1 Ghz; 15")'s sleep.

I believe it's only possible on desktop machines. Powerbooks have a depper sleep.

Darn! Oh well. I was hoping I can put the PowerBook to sleep when I close the case, carry downstair/upstair, etc. without losing network. --
"I'm not afraid of insects taking over the world, and you know why? It would take about a million ants just to aim a gun at me, let alone fire it. And you know what I'm doing while they're aiming it at me? I just sort of slip off to the side, and then suddenly run up and kick the gun out of their hands." --Jack Handy from Saturday Night Live /\___/\
/ /\ /\ \ Ant @ The Ant Farm: http://antfarm.ma.cx

o o| | E-mail: philpi@earthlink.netANT or philpi@apu.eduANT

\ _ / Remove ANT if replying by e-mail from a newsgroup.

( )

Message #4 - Posted 2004/02/05 - P M Evans

Previously, <ANTant@zimage.com> wrote:

Darn! Oh well. I was hoping I can put the PowerBook to sleep when I close the case, carry downstair/upstair, etc. without losing network.

I donπt understand the problem. It should reestablish the connection as soon as you wake it up anyway. I have an iBook that never is shut down. I take it to meetings where we have an Airport set up, and it connects to the new network in a matter of seconds when I open it. When I get home, it automatically switches back to my home Airport.

Message #5 - Posted 2004/02/05 - ANTant

P M Evans wrote:

Previously, <ANTant@zimage.com> wrote:

Darn! Oh well. I was hoping I can put the PowerBook to sleep when I close the case, carry downstair/upstair, etc. without losing network.

I donπt understand the problem. It should reestablish the connection as soon as you wake it up anyway. I have an iBook that never is shut down. I take it to meetings where we have an Airport set up, and it connects to the new network in a matter of seconds when I open it. When I get home, it automatically switches back to my home Airport.

Not if I am in the middle of a download, streaming video, and using ssh. Those, I have to reconnect manually if I were to close my PowerBook unless I missed something.
--
"I'm not afraid of insects taking over the world, and you know why? It would take about a million ants just to aim a gun at me, let alone fire it. And you know what I'm doing while they're aiming it at me? I just sort of slip off to the side, and then suddenly run up and kick the gun out of their hands." --Jack Handy from Saturday Night Live /\___/\
/ /\ /\ \ Ant @ The Ant Farm: http://antfarm.ma.cx

o o| | E-mail: philpi@earthlink.netANT or philpi@apu.eduANT

\ _ / Remove ANT if replying by e-mail from a newsgroup.

( )

Message #6 - Posted 2004/02/23 - ANTant

I heard it is possible to disable this in MacOS X (10.2.8). How do I do that? I do not see this option in Energy Saver option. I would like to keep AirPort and NIC going during PowerBook G4 (1 Ghz; 15")'s sleep.

I believe it's only possible on desktop machines. Powerbooks have a depper sleep.

Now, this is an interesting suggestion:
http://www.macosxhints.com/article.php?story=20040214162448260

I do not have the PowerBook G4 with me to try it now. Will this work? --
"I don't understand them anymore, these people that travel the commuter-trains to their dormitory towns. These people call themselves human, but, by a pressure they do not feel, are forced to do their work like ants. With what do they fill their time when they are free of work on their silly little Sundays?" --Antoine de saint-ExupÈry, 'Wind, Sand, and Stars,' 1939
/\___/\
/ /\ /\ \ Ant @ The Ant Farm: http://antfarm.ma.cx

o o| | E-mail: philpi@earthlink.netANT or philpi@apu.eduANT

\ _ / Remove ANT if replying by e-mail from a newsgroup.

( )

Message #7 - Posted 2004/03/14 - Clark Martin

Previously, ANTant@zimage.com wrote:

I heard it is possible to disable this in MacOS X (10.2.8). How do I do that? I do not see this option in Energy Saver option. I would like to keep AirPort and NIC going during PowerBook G4 (1 Ghz; 15")'s sleep.

I believe it's only possible on desktop machines. Powerbooks have a depper sleep.

Now, this is an interesting suggestion:
http://www.macosxhints.com/article.php?story=20040214162448260

I do not have the PowerBook G4 with me to try it now. Will this work?

There isn't much way around this. When the computer goes to sleep it becomes dead to the world until you wake it up. It isn't that programs on your computer disconnect from the server as the server drops the connection. This applies to "live" connections such as AppleShare, Timbuktu, Filemaker and others. Things like web pages and ftp only connect (usually) when you do something so there is no connection to break while the computer is sleeping.

There is the option in Energy saver to wake on Network Administrator access but I haven't had any success with this using Apple Remote Desktop.

Note that there is a distinction between the computer going to sleep and the display and harddrive sleeping. When the computer goes to sleep it powers down almost everything so it is inherently difficult to have network activity wake it up althought it is supposed to. Even if the computer wakes up the network software at the other end may give up before the computer is awake.

Clark Martin
Redwood City, CA, USA Macintosh / Internet Consulting

"I'm a designated driver on the Information Super Highway"

Message #8 - Posted 2004/03/15 - Neill Massello

Clark Martin wrote:

There is the option in Energy saver to wake on Network Administrator access but I haven't had any success with this using Apple Remote Desktop.

You need to send a special ("magic") packet to the sleeping Mac via the Ethernet LAN. To do this, enter the Mac's MAC address into WakeUp <http://www.coriolis.ch/article5.html>.

Need Help? Have a Question?

Looking for more help, comments, and answers?

Ask your questions on Ask Different. Ask Different is a community of Apple users ready to help.