The conversation on this page has been archived and is no longer active.

Keyboard command for sleep

Message #1 - Posted 2007/03/18 - Alan

For a G3 iMac with 10.4.9: I always used to put the Mac to sleep by pressing Control-Eject. All of a sudden this shortcut won't work and I need to choose Sleep from the Apple menu.

Why is this? Could I have disabled the command somehow? Is it a result of installing various updates to the system?

Thanks,

Alan

Message #2 - Posted 2007/03/18 - David Empson

Alan wrote:

For a G3 iMac with 10.4.9: I always used to put the Mac to sleep by pressing Control-Eject. All of a sudden this shortcut won't work and I need to choose Sleep from the Apple menu.

Why is this? Could I have disabled the command somehow? Is it a result of installing various updates to the system?

Apple introduced a delay on the eject key with 10.4.9: you have to hold it down briefly to make it open the CD drawer or eject a CD.

This delay also affects the Ctrl-Eject keyboard combination, so you have to hold the Eject key down for a little time before the dialog box appears.

I have no complaint about the delay for the eject key by itself - I'm often accidentally opening my PowerMac G4's drive tray when I bump that corner of the keyboard.

The delay for Ctrl-Eject is a major nuisance. I've never hit that particular combination by mistake, and now I have to twiddle my thumbs waiting for it.

It will also affect the other key combinations involving the eject key (e.g. Ctrl-Option-Cmd-Eject to do an immediate shutdown).

I haven't installed 10.4.9 on my own computers yet so I haven't investigated this delay closely. It might be implemented by waiting for the auto-repeat to kick in for the Eject key, in which case the time of the delay will vary depending on your system preference setting for the auto repeat delay, and if you have completely disabled auto repeat then this might defeat your eject key as well. (I hope Apple wasn't that stupid when adding this "feature".)

David Empson
dempson@actrix.gen.nz

Message #3 - Posted 2007/03/18 - Kir?ly

Alan wrote:

For a G3 iMac with 10.4.9: I always used to put the Mac to sleep by pressing Control-Eject. All of a sudden this shortcut won't work and I need to choose Sleep from the Apple menu.

Why is this? Could I have disabled the command somehow? Is it a result of installing various updates to the system?

Control-Eject? Command-option-eject has always done it for me, and is still working under 10.4.9. I do have to hold down the eject key for a little bit longer, though.

K.

Lang may your lum reek.

Message #4 - Posted 2007/03/18 - Jochem Huhmann

dempson@actrix.gen.nz (David Empson) writes:

The delay for Ctrl-Eject is a major nuisance. I've never hit that particular combination by mistake, and now I have to twiddle my thumbs waiting for it.

It will also affect the other key combinations involving the eject key (e.g. Ctrl-Option-Cmd-Eject to do an immediate shutdown).

I have already filed this as a bug with Apple and they ackknowledged this is a "known issue" and investigated right now. So there is hope that this "feature" will be fixed sooner or later...

Jochem

"A designer knows he has arrived at perfection not when there is no longer anything to add, but when there is no longer anything to take away." - Antoine de Saint-Exupery

Message #5 - Posted 2007/03/18 - TaliesinSoft

On Sun, 18 Mar 2007 02:11:03 -0500, David Empson wrote (in a previous article):

The delay for Ctrl-Eject is a major nuisance. I've never hit that particular combination by mistake, and now I have to twiddle my thumbs waiting for it.

In the half of a second it takes the Ctrl-Eject keystroke to take effect I hardly have the time to tell where my thumbs are! :-)

James Leo Ryan ..... Austin, Texas ..... taliesinsoft@mac.com

Message #6 - Posted 2007/03/18 - Neill Massello

David Empson wrote:

I haven't installed 10.4.9 on my own computers yet so I haven't investigated this delay closely. It might be implemented by waiting for the auto-repeat to kick in for the Eject key, in which case the time of the delay will vary depending on your system preference setting for the auto repeat delay, and if you have completely disabled auto repeat then this might defeat your eject key as well. (I hope Apple wasn't that stupid when adding this "feature".)

The repeat settings had no effect on the eject key's responsiveness on my PowerMac G5.

It should be noted that delayed response to the eject key has been standard behavior on laptops for a long time. It's now consistent across all Mac models. One change I welcome is that the optical drive tray now stays open when the eject key is held down during startup, rather than playing whack-a-mole by closing after a few seconds.

Message #7 - Posted 2007/03/19 - Clever Monkey

Kir·ly wrote:

Alan wrote:

For a G3 iMac with 10.4.9: I always used to put the Mac to sleep by pressing Control-Eject. All of a sudden this shortcut won't work and I need to choose Sleep from the Apple menu.

Why is this? Could I have disabled the command somehow? Is it a result of installing various updates to the system?

Control-Eject? Command-option-eject has always done it for me, and is still working under 10.4.9. I do have to hold down the eject key for a little bit longer, though.

My understanding is that cmd-opt-eject is the magic keystroke to sleep a Mac, and one I've been using for about a year since I heard of it. I also note that it takes a little longer to recognize the eject key, so I had to readjust my muscle memory.

Need Help? Have a Question?

Looking for more help, comments, and answers?

Ask your questions on Ask Different. Ask Different is a community of Apple users ready to help.