The conversation on this page has been archived and is no longer active.

Startup Message: Couldn't find root user. Sleeping and trying again.

Message #1 - Posted 2008/04/05 - Kurt R. Todoroff

Previously, JF Mezei wrote:

billy@MIX.COM wrote:

Just do this from a terminal session -

sudo nvram boot-args="-v"

Many thanks ! I remember an old utility on 68k based macs called "Pram". But this one seems far more powerful.

I performed the procedures in Apple's article 107210 "Mac OS X, Mac OS X Server: How to Replace the NetInfo Database (Restoring from defaults). This did not solve the problem.

I booted from the suspect internal hard drive into single user mode.

I ran /sbin/fsck -fy on the internal hard drive.
All tests passed.

I ran fsck_hfs on the internal hard drive.
It returned a message that stated that I needed
to add additional information.
I ran fsck_hfs with several switches enabled, but
it continued to return this message.

I booted this computer from my external Firewire hard drive that I use to create nightly backups on my G4 iMac using SuperDuper!.

I ran Disk Utility Repair Disk Permissions on the
internal hard drive.
There were no permissions errors.

I ran Disk Utility Repair Disk.
All tests passed.

I ran the TechTool Pro Suites --> Advanced Tests on
the internal hard drive.
All tests passed except for "Startup File" which it listed as " <Not Present>".
The description of this test is:

"This test checks the Startup file. The parameters within this file contain the information used by
the computer ROM to determine what program will
boot the computer as well as other system-specific aspects."

I ran the TechTool Pro Performance --> Maintenance routine on the internal hard drive.
It completed the maintenance successfully.

I ran DiskWarrior on the internal hard drive.
It reported no directory errors, but I replaced it
anyway.

While booted from the external Firewire hard drive, I viewed what appears to be the proper compliment of folders on the internal hard drive. Of course, I didn't examine and verify every subfolder in the hierarchy, however, examining the Applications, Library, System, and Users folders two deep seemed to indicate that everything was there.

I booted this computer from my Tiger installation disk. I selected Utilities --> Reset Password... (I think.). It listed only the Administrator account (root) on the internal hard drive. It did not list the other three accounts that I created on this hard drive, even all three respective folders are present in the Users folder. However, it did list all four accounts on the still attached external Firewire hard drive.

By every measure, this drive and its directory are sound. I am concerned that TechTool Pro reported that the Startup File is Not Present. Beyond the meaning that the words suggest, I'm not sure what this really means. I checked the Micromat site and found the following:

The Startup File has been defined but not yet
implemented by Apple.

Suggestions?

Thank you.

--

Kurt Todoroff
kurt.r.todoroff@comcast.net

Markets, not mandates and mob rule.
Consent, not coercion.

Need Help? Have a Question?

Looking for more help, comments, and answers?

Ask your questions on Ask Different. Ask Different is a community of Apple users ready to help.