The conversation on this page has been archived and is no longer active.

Waking up the computer via telephone

Message #1 - Posted 2005/03/26 - Andrew J. Brehm

In the Energy Saver control panel there is one "Wake Option" named "Wake when the modem detecs a ring".

I checked it and put the computer to sleep, then rang my phone number (from a mobile). The modem is connected to my phone line and works fine for dialing.

But the computer didn't wake up.

I also disconnected my phone so that only the modem would be connected to the phone line, and rang my number again.

Again, the computer didn't wake up.

What am I missing here?

Andrew J. Brehm <ajbrehm@gmail.com>
Marx Brothers Fan
PowerPC/Macintosh User
Supporter of Chicken Sandwiches

Message #2 - Posted 2005/03/26 - Tom Stiller

Previously, Andrew J. Brehm wrote:

In the Energy Saver control panel there is one "Wake Option" named "Wake when the modem detecs a ring".

I checked it and put the computer to sleep, then rang my phone number (from a mobile). The modem is connected to my phone line and works fine for dialing.

But the computer didn't wake up.

I also disconnected my phone so that only the modem would be connected to the phone line, and rang my number again.

Again, the computer didn't wake up.

What am I missing here?

I think you have to enable "Receive faxes on this computer" in the "Print & Fax" system preferences.

Tom Stiller

PGP fingerprint = 5108 DDB2 9761 EDE5 E7E3
7BDA 71ED 6496 99C0 C7CF

Message #3 - Posted 2005/03/26 - Andrew J. Brehm

Tom Stiller wrote:

Previously, Andrew J. Brehm wrote:

In the Energy Saver control panel there is one "Wake Option" named "Wake when the modem detecs a ring".

I checked it and put the computer to sleep, then rang my phone number (from a mobile). The modem is connected to my phone line and works fine for dialing.

But the computer didn't wake up.

I also disconnected my phone so that only the modem would be connected to the phone line, and rang my number again.

Again, the computer didn't wake up.

What am I missing here?

I think you have to enable "Receive faxes on this computer" in the "Print & Fax" system preferences.

That does it.

However, is this supposed to take very very long?

When I did this last night (it was one of the things I tried), my iMac hung and needed a cold-boot to come back alive. That is it came back to the login screen after manually removed the Virex startup item in /Library in single user mode because it wouldn't boot to the login screen with the item being there for some reason.

(I can't tell you how long it took me to isolate one startup item as the culprit!)

When I tried checking the Receive faxes marker now, my iMac hung again and I could access no other application and pressing apple-option-esc didn't bring up the application list, so I could not end the System Preferences either.

After another cold-boot (I gave up after five minutes of waiting) which for some reason didn't involve removing the Virex startup item (I had reinstalled Virex), the iMac is now up and running again, the Receive faxes marker is checked and it does wake up when the number is called.

Weird!

Just when I was closing the message above the computer hung again and needed another cold-boot. This iMac is usually very stable and gets rebooted only once a month or so, whenever a security update is other OS X update is installed.

Luckily Mac-SOUP appears to have saved the message...

Weird!!

Andrew J. Brehm <ajbrehm@gmail.com>
Marx Brothers Fan
PowerPC/Macintosh User
Supporter of Chicken Sandwiches

Message #4 - Posted 2005/03/26 - Andrew J. Brehm

Andrew J. Brehm wrote:

Tom Stiller wrote:

I think you have to enable "Receive faxes on this computer" in the "Print & Fax" system preferences.

That does it.

However, is this supposed to take very very long?

When I did this last night (it was one of the things I tried), my iMac hung and needed a cold-boot to come back alive. That is it came back to the login screen after manually removed the Virex startup item in /Library in single user mode because it wouldn't boot to the login screen with the item being there for some reason.

(I can't tell you how long it took me to isolate one startup item as the culprit!)

When I tried checking the Receive faxes marker now, my iMac hung again and I could access no other application and pressing apple-option-esc didn't bring up the application list, so I could not end the System Preferences either.

After another cold-boot (I gave up after five minutes of waiting) which for some reason didn't involve removing the Virex startup item (I had reinstalled Virex), the iMac is now up and running again, the Receive faxes marker is checked and it does wake up when the number is called.

Weird!

Just when I was closing the message above the computer hung again and needed another cold-boot. This iMac is usually very stable and gets rebooted only once a month or so, whenever a security update is other OS X update is installed.

Luckily Mac-SOUP appears to have saved the message...

Weird!!

I investigated a bit more.

It appears that my iMac hangs after a while whenever Receiving faxes is checked, whether the phone line is connected to the modem or not. And even when I disable Receiving faxes the computer still hangs after a while.

But it seems to work fine after a reboot when Receiving faxes is turned off.

I also had a terminal window and a CPU-meter running for the experiments. The terminal window doesn't react any more when the computer hangs (this is how I know it hangs, apple-option-esc doesn't work either) and the CPU-meter (from Activity Monitor) doesn't move any more.

I have not tried the whole thing after uninstalling Virex because now I want to know whether there are any known issues with Virex and receiving faxes, however improbable that might sound, before I prepare to choose between them.

Weird.

Andrew J. Brehm <ajbrehm@gmail.com>
Marx Brothers Fan
PowerPC/Macintosh User
Supporter of Chicken Sandwiches

Message #5 - Posted 2005/03/26 - Andrew J. Brehm

Andrew J. Brehm wrote:

I have not tried the whole thing after uninstalling Virex because now I want to know whether there are any known issues with Virex and receiving faxes, however improbable that might sound, before I prepare to choose between them.

And here it is:

<http://www.macfixit.com/article.php?story=20050303072141872>

Andrew J. Brehm <ajbrehm@gmail.com>
Marx Brothers Fan
PowerPC/Macintosh User
Supporter of Chicken Sandwiches

Message #6 - Posted 2005/03/26 - Andrew J. Brehm

Andrew J. Brehm wrote:

Andrew J. Brehm wrote:

I have not tried the whole thing after uninstalling Virex because now I want to know whether there are any known issues with Virex and receiving faxes, however improbable that might sound, before I prepare to choose between them.

And here it is:

<http://www.macfixit.com/article.php?story=20050303072141872>

I solved the problem by uninstalling Virex.

What were Apple thinking????

Andrew J. Brehm <ajbrehm@gmail.com>
Marx Brothers Fan
PowerPC/Macintosh User
Supporter of Chicken Sandwiches

Message #7 - Posted 2005/03/26 - Andrew J. Brehm

Andrew J. Brehm wrote:

Andrew J. Brehm wrote:

Andrew J. Brehm wrote:

I have not tried the whole thing after uninstalling Virex because now I want to know whether there are any known issues with Virex and receiving faxes, however improbable that might sound, before I prepare to choose between them.

And here it is:

<http://www.macfixit.com/article.php?story=20050303072141872>

I solved the problem by uninstalling Virex.

What were Apple thinking????

Installed ClamAV. Problem thus solved. Thanks ClamAV.

<http://www.markallan.co.uk/clamXav/>

Andrew J. Brehm <ajbrehm@gmail.com>
Marx Brothers Fan
PowerPC/Macintosh User
Supporter of Chicken Sandwiches

Message #8 - Posted 2005/03/26 - Tom Stiller

Previously, Andrew J. Brehm wrote:

Andrew J. Brehm wrote:

Andrew J. Brehm wrote:

I have not tried the whole thing after uninstalling Virex because now I want to know whether there are any known issues with Virex and receiving faxes, however improbable that might sound, before I prepare to choose between them.

And here it is:

<http://www.macfixit.com/article.php?story=20050303072141872>

I solved the problem by uninstalling Virex.

What were Apple thinking????

That Virex is a piece of ****?

Tom Stiller

PGP fingerprint = 5108 DDB2 9761 EDE5 E7E3
7BDA 71ED 6496 99C0 C7CF

Message #9 - Posted 2005/03/31 - Andrew J. Brehm

Tom Stiller wrote:

Previously, Andrew J. Brehm wrote:

In the Energy Saver control panel there is one "Wake Option" named "Wake when the modem detecs a ring".

I checked it and put the computer to sleep, then rang my phone number (from a mobile). The modem is connected to my phone line and works fine for dialing.

But the computer didn't wake up.

I also disconnected my phone so that only the modem would be connected to the phone line, and rang my number again.

Again, the computer didn't wake up.

What am I missing here?

I think you have to enable "Receive faxes on this computer" in the "Print & Fax" system preferences.

This is now working as I said in an earlier posting

However, there appears to be a rather idiotic problem now in as much as the computer actually falls asleep again within a few seconds after the ring when no fax as been received (as none was sent to it). This happens even when I am logged in via SSH.

Is there a way to make Mac OS X not fall asleep when a user is using the computer?

Andrew J. Brehm
Marx Brothers Fan
PowerPC/Macintosh User
Supporter of Chicken Sandwiches

Need Help? Have a Question?

Looking for more help, comments, and answers?

Ask your questions on Ask Different. Ask Different is a community of Apple users ready to help.