The conversation on this page has been archived and is no longer active.

Wallstreet battery not charging

Message #1 - Posted 2004/03/02 - belcanto

Previously, markc wrote:

Hi all,

I guess this is an old subject but I could use some advice and havent found anything that works searching the internet. I am trying to make sure my daughters wallstreet is working properly so I can sell it. It turns out the battery might be worn out, so I bought one that is supposed to be new from ebay. The powerbook wont see this battery at all, the old battery will show up sometimes but never shows that it is charging. I thought the problem was the battery charge board so I replaced that one with another used one and nothing changed. I have tried shoving the battery in both slots a hundred different ways and havent been able to boot to open firmware to try that trick.

I am getting tired of this little game of playing with batteries and taking the laptop apart. Any ideas would be appreciated.

Wallstreet 266
OS 8.5

Mark

I had the same problem with a new Wall Street battery. Seems Apple found a bettery charging problem with some of their G3 and iBook laptops. To fix it you have to download from Apple (or from www.batterytech.com) a BATTERY RESET 2.0 patch. I tried it and it works.

Good luck,

Stephen

Need Help? Have a Question?

Looking for more help, comments, and answers?

Ask your questions on Ask Different. Ask Different is a community of Apple users ready to help.